Debian dla-3713 : libcppunit-subunit-dev - security update

high Nessus Plugin ID 189267

Synopsis

The remote Debian host is missing a security-related update.

Description

The remote Debian 10 host has packages installed that are affected by a vulnerability as referenced in the dla-3713 advisory.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade the libcppunit-subunit-dev packages.

See Also

https://security-tracker.debian.org/tracker/source-package/subunit

https://packages.debian.org/source/buster/subunit

Plugin Details

Severity: High

ID: 189267

File Name: debian_DLA-3713.nasl

Version: 1.0

Type: local

Agent: unix

Published: 1/21/2024

Updated: 1/21/2024

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

Vulnerability Information

CPE: cpe:/o:debian:debian_linux:10.0, p-cpe:/a:debian:debian_linux:libcppunit-subunit-dev, p-cpe:/a:debian:debian_linux:libcppunit-subunit0, p-cpe:/a:debian:debian_linux:libsubunit-dev, p-cpe:/a:debian:debian_linux:libsubunit-perl, p-cpe:/a:debian:debian_linux:libsubunit0, p-cpe:/a:debian:debian_linux:python-subunit, p-cpe:/a:debian:debian_linux:python3-subunit, p-cpe:/a:debian:debian_linux:subunit

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 1/21/2024

Vulnerability Publication Date: 1/21/2024